[kernel-xen] VM restarting too fast (Elapsed time: 0.725362 seconds). Refusing to restart to avoid loops

Callum Venmans || LiteServer.nl cvenmans at liteserver.nl
Fri Oct 26 19:39:02 EST 2012

Hi All,

Some time ago I decided to give Xen 4.2 a test on my new nodes running 
on Ivy Bridge hardware, as Xen 4.1.3 on thoe host didn't boot properly.
Xen 4.2 runs and boots fine of this new box, so that issue is 
fortunately solved.
But since Xen 4.2.0 i'm having issues with Xen PV VM's that are using a 
kernel 3.x.x kernel. All OSes based on the 2.6.x kernel doesn't have 
these problems.

When I create a new VM under PV (I'm using template for Stacklet.com 
which always worked fine on previous Xen versions), and using a OS like 
Ubuntu 12.04 it refuses to boot - the guest crashes immediate.
Too make sure it's not hardware related, I tried some older Intel and 
AMD systems which always ran great on Xen 4.1. Fresh install with Xen 
4.2.0, and immediately the same issue:

3345] INFO (XendDomain:1225) Domain testing (50) unpaused.
3345] WARNING (XendDomainInfo:2062) Domain has crashed: name=vm1358 id=50.
3345] ERROR (XendDomainInfo:2196) VM testing restarting too fast 
(Elapsed time: 0.725362 seconds). Refusing to restart to avoid loops.
3345] DEBUG (XendDomainInfo:3077) XendDomainInfo.destroy: domid=50
3345] DEBUG (XendDomainInfo:2402) Destroying device model
3345] DEBUG (XendDomainInfo:2409) Releasing devices
3345] DEBUG (XendDomainInfo:2415) Removing vif/0
3345] DEBUG (XendDomainInfo:1276) XendDomainInfo.destroyDevice: 
deviceClass = vif, device = vif/0
3345] DEBUG (XendDomainInfo:2415) Removing console/0
3345] DEBUG (XendDomainInfo:1276) XendDomainInfo.destroyDevice: 
deviceClass = console, device = console/0
3345] DEBUG (XendDomainInfo:2415) Removing vbd/51713
3345] DEBUG (XendDomainInfo:1276) XendDomainInfo.destroyDevice: 
deviceClass = vbd, device = vbd/51713
3345] DEBUG (XendDomainInfo:2415) Removing vbd/51714
3345] DEBUG (XendDomainInfo:1276) XendDomainInfo.destroyDevice: 
deviceClass = vbd, device = vbd/51714

This is how they all start, including the OSes with an older kernel. I'm 
always using the OS kernel from the template - so each OS has basically 
it's own kernel.
3345] INFO (image:186) buildDomain os=linux dom=50 vcpus=2
3345] DEBUG (image:725) domid          = 50
3345] DEBUG (image:726) memsize        = 512
3345] DEBUG (image:727) image          = 
3345] DEBUG (image:728) store_evtchn   = 1
3345] DEBUG (image:729) console_evtchn = 2
3345] DEBUG (image:730) cmdline        = root=/dev/xvda1 ro
3345] DEBUG (image:731) ramdisk        = 
3345] DEBUG (image:732) vcpus          = 2
3345] DEBUG (image:733) features       =
3345] DEBUG (image:734) flags          = 0
3345] DEBUG (image:735) superpages     = 0

All other OSes are running great, as long they are using a 2.6.x kernel.
The host is running on Kernel 3.6.2 (fresh installed from the repo), but 
the problem was also there with Kernel 3.5.4. It really has something to 
do with Xen 4.2.

I'm already digging into this for a couple days, but not found any 
usable errors.
The VM crashes immediately, so I tried the "prereserve" or something 
like that flag to avoid looping, but the console stays black.

More information about the kernel-xen mailing list